Friday, 8 January 2016

BBC Bridge Companion (MESS has the wrong background color)

Yup, i'm still alive! =)

For starting this new year, my first post of 2016 will be on the Unicard BBC Bridge Companion. Some of you already knows that this obscure game system is already emulated in MAME (MESS is now integrated with MAME) with all released game cartridges dumped.

As i was checking out the emulation, i have notice that, first of all, there is no sounds while playing any of the games. Humm...maybe the driver wasn't still finished even if the status on the driver is "good".I'll come back later on the sound issue. Now for the second thing: as i'm testing all the games, i notice that they display a "beige-type" background color....? "Beige" ? Err...if i remember correctly, the game system produce a "light green/light lime" background color, not beige. But the big problem is that i have sold my Bridge Companion (with an extra game) a year or more ago.

So i have brought another Bridge Companion to see if my memories were true so once i received the game system, i modded it with composite video (i hate those &?*&?& RF switch box!) and tested it on my mini TFT monitor which can display either NTSC or PAL and on my computer with the help of a Adesso AV-200 USB video capture device. And guess what ?

Video capture with Adesso AV-200




That proves that i still have a good memory! (especially when you're getting older, it's conforting to see your memory still sharp). And check out the two videos i've uploaded on Youtube:

(In PAL mode)

(in SECAM mode)

and more proof that it has a light green background (and not beige):


(screenshot picture taken from Ebay UK)




So hoping that in a future version of MESS (ahhh man! MAME!), that the "bbcbc" driver will be corrected with the proper background color. ;)

OK now back to the sound issue. At first i thought that the driver wasn't finished...i was wrong! As a matter of fact, the driver for the sounds is just correct. It turns out that the game system doesn't make any sounds! YES!! I'm not joking! The Bridge Companion doesn't make any sounds at all, not on the TV or with a built-in speaker...zip! nada! NO SOUNDS!! 

What the %*&%/? at Herber LTD thought when they conceived the Bridge Companion ?! Hello! it was 1985! Not 1975! I can accept that some few Pong consoles doesn't make any sounds (hey...it was the beginning) but by 1985 ?!? Now that is so lame!! At least they should have designed a small sound circuit to make one or two beeps. I discovered that when i did the A/V...oups!... Video mod as the composite video enter the Astec UM1233 RF modulator but this particular modulator is intended just to process video signal and output to UHF, and it is not intended for sound(s). So don't waste time to write " Hey! The emulation doesn't work "Dude"! It doesn't make any sounds!".

It's simply that it never will make any sounds....period! So this scratches off the sound issue, but there still the background color issue to correct in a near future. Meanwhile, here's more pictures:

(opening the beast to mod it)

PAL game system on a NTSC TV, that what it does:
Vertical keeps on rolling and no colors.



 EPROM! Great so i can change the EPROM
with other i can burn with the dumped binaries.


EOF! (for now!) =)


No comments:

Post a Comment